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Introduction 
 

COBie is the abbreviation of Construction Operations Building Information Exchange, a specification used in 

the handover of Facility Management information. It is a spreadsheet data format for the delivery of a 

subset of building model information, rather than geometric model information. 

Although ArchiCAD cannot export COBie spreadsheets directly, ArchiCAD’s BIM-quality models and IFC data 

exchange capabilities produces data output that is easily converted into COBie documentation, with the help 

of free or commercial conversion programs. 

What is the relationship between IFC and COBie?  

The COBie spreadsheet is a mapping of the FM Handover View Definition, which is a subset (so-called 

“Model View Definition” (MVD)) of the current IFC 2x3 scheme. FM Handover View Definition was developed 

by buildingSMART to exchange facility management information among building models. ArchiCAD 17’s IFC 

2x3 interface and database support the IFC data and model export requirements of the FM Handover View 

Definition, so most of the values of the COBie spreadsheet cells are extracted from IFC models exported by 

ArchiCAD 17 according to the FM Handover MVD settings. 

Hint To read more information about the relation between IFC 2x3 FM Handover and COBie, visit the 

buildingSMART website by clicking here. 

This paper provides practical information on which data to add to an ArchiCAD project and how to export it 

as an IFC model, to obtain a format suitable for producing a COBie2 (or current-version COBie) spreadsheet. 

The final chapter consists of a sample workflow using a free IFC-COBie2 conversion tool recommended by 

buildingSMART. 

Hint For detailed documentation about ArchiCAD’s IFC capabilities, visit the Graphisoft website by clicking 

here. 

 

 

 

 

 

 

 

  

http://www.buildingsmart-tech.org/specifications/ifc-view-definition/fm-handover-aquarium/fm-aquarium-cobie2-description/fm-aquarium-cobie2-description
http://www.graphisoft.com/support/ifc/downloads/
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ArchiCAD Model Preparation for COBie2 
 

The FM Handover View Definition used by COBie2 queries the following IFC data types from an architectural 

model and/or its elements: 

- IFC Attributes 

- IFC Properties (standard IFC 2x3 and COBie2-required properties) 

- IFC Classification Reference 

- IFC Zone 

- IFC System 

- IFC Type Product 

- Base quantities 

- Space containment relation 

- Space boundary relation 

All of these data types can be created in ArchiCAD 17 using one or more of these functions: 

- Element Settings dialog boxes 

- the IFC Manager tool 

- IFC Translator settings used for IFC model export 

This chapter summarizes the data (required from a design application) to be provided in ArchiCAD 17 for use 

by the COBie2 spreadsheet worksheet. 

 

Figure 1   The worksheets of the COBie2 spreadsheet 

 

 

 

 



6 
 

Key to tables displayed in the following sections of this document: 

 COBie2 data taken directly from data that was input in ArchiCAD. In other words, the 
ArchiCAD and IFC data types corresponding to these COBie data must be set or created in our 
ArchiCAD model. 
 

 COBie2 data that are automatically extracted from the IFC model saved from ArchiCAD. 
 

 COBie2 data not extracted from the IFC scheme. These data must therefore be manually filled 
out in the COBie2 spreadsheet later. 
 

 

Contact 
 

The COBie2 Contact worksheet summarizes the person and organization data of the project/model designer. 

 

Figure 2   Mapping between ArchiCAD model and the COBie2 Contact worksheet data 

ArchiCAD project data must be assigned to correspond with the COBie2 items marked in green (the rest of 

the data are automatically extracted from the IFC model saved from ArchiCAD). 

The Person and Organization data can be entered in ArchiCAD’s IFC Options dialog box (File > File Special > 

IFC 2x3). Both „Postal” and „Telecom” address types must be defined. 
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Figure 3   Contact data in ArchiCAD (Person and Organization) 

Facility 
 

The COBie2 Facility worksheet summarizes the Facility (IfcBuilding), Project (IfcProject) and Site (IfcSite) 

data. 

 

Figure 4   Mapping between ArchiCAD model and the COBie2 Facility worksheet data 
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The “Name” data of the Facility worksheet can be set in ArchiCAD at Project Info (File > Info) by defining the 

“Project Name” data. The main Facility data can be defined as IfcBuilding data in the IFC Manager dialog (File 

> File Special > IFC 2x3). 

To set the Facility Category, define Classification Reference data in the IFC Manager. COBie requires 

IfcBuilding classification by the OmniClass table 11 ('Construction Entities by Function'), so choose the proper 

classification value from the built-in “Table 11 – Construction Entities by Function” (OmniClass) list under 

“Apply Predefined Rule” option. The ArchiCAD classification rule based on Uniclass tables is also available in 

UK. 

 

Figure 5   IfcBuilding data set by Project Info and IFC Manager 

Other Facility data such as the IFC Attributes of the IfcProject and the IfcSite entities can be set in the IFC 

Manager dialog. 
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Figure 6   IfcProject and IfcSite data set by IFC Manager 

The unit system of the Facility can be set in the IFC Translator’s Export Options which are fine-tuned for IFC 

model export required for COBie2 (“FM Handover.COBie”; see chapter COBie2-enabled IFC Model Export). 
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Figure 7   Unit settings of the IFC Translator 

 

Floor 
 

The COBie2 Floor worksheet summarizes data of the Stories (IfcBuildingStorey) of the project. 

 

Figure 8   Mapping between ArchiCAD model and the COBie2 Floor worksheet data 

The “Floors” are interpreted as Stories in the ArchiCAD project. Thus, the Floor Names are derived from the 

ArchiCAD Story names. 
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To set the Floor Category, define a “FloorType”-named Classification Reference data item in the IFC 

Manager. COBie requires one of the following values for the “Name” Attribute of the Classification 

Reference: Floor, Roof or Site. 

The ”Description” IFC Attribute of an ArchiCAD Story (IfcBuildingStorey) can also be set via the IFC Manager. 

 

Figure 9   Floor data in ArchiCAD 

 

Space 
 

The COBie2 Space worksheet summarizes data of the Spaces (IfcSpace) of the project. 

 

Figure 10   Mapping between ArchiCAD model and the COBie2 Space worksheet data 
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The “Spaces” are interpreted as Zones (IfcSpaces) in the ArchiCAD project. Thus, the COBie2-required data 

can be set in ArchiCAD Zone Settings. IFC data can be set using the “Manage IFC Properties” option (Tags and 

Categories tab). 

To set the Space Category, define Classification Reference data in the IFC Manager or in the Zone Settings 

Dialog. COBie requires IfcSpace classification by the OmniClass table 13 (‘Space by Function'), so choose the 

proper classification value from the built-in “Table 13 – Space by Function” (OmniClass) list under “Apply 

Predefined Rule” option. ArchiCAD classification rule based on Uniclass tables is also available in UK. 

“Name” and “Description” COBie2 items are derived from the “No.” and the “Zone Name” Attributes of the 

ArchiCAD Zone, which can be set in Zone Settings. 

 

Figure 11   Space data in ArchiCAD 

To make the COBie2-required “RoomTag” IFC Property available for the Spaces in the IFC Manager and the 

Setting Dialogs (Tags and Categories > Manage IFC Properties), import the “COBie2-PropertySet.xml” scheme 

into the ArchiCAD project (see chapter Component). The XML-type scheme can be added to the project with 

the IFC Scheme Setup command (File > File Special > IFC 2x3). 
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Zone 
The COBie2 Zone worksheet summarizes the sets of spaces sharing a specific attribute in the project. In 

other words, it summarizes the data of the groups (IfcZones) of Spaces (IfcSpaces). 

 

Figure 12   Mapping between ArchiCAD model and the COBie2 Zone worksheet data 

The “Zones” are interpreted as IfcZone Assignment in the ArchiCAD project. IfcZones (group of IfcSpaces 

(ArchiCAD Zones)) and their COBie2-requested data can be defined in the IFC Manager only. 

First, create an IfcZone by clicking the “New” command from the “IFC Zones” item in the “Assignments” tree, 

then drop the IfcSpaces (ArchiCAD Zones) to the “New Relation” folder of the new IfcZone entity from the 

Project tree of the IFC Manager. 

To set the Zone Category, define a “ZoneType”-named Classification Reference data in the IFC Manager. 

COBie requires one of the following values for the “Name” Attribute of the Classification Reference: 

- Circulation Zone, 

- Lighting Zone, 

- Fire Alarm Zone, 

- Historical Preservation Zone, 

- Occupancy Zone, or 

- Ventilation Zone. 

Figure 13   Zone definition 
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Type 
 

COBie2 Type worksheet summarizes the types of equipment and products. 

 

Figure 14   Mapping between ArchiCAD model and the COBie2 Type worksheet data 

The “Types” are interpreted as IFC Type Product entities in the ArchiCAD project. IFC Type Products and their 

COBie2-requested data can be defined in the IFC Manager only. ArchiCAD automatically generates IFC Type 

Product entities for all ArchiCAD element types. The following table shows some naming examples of the 

automatically generated IFC types. Of course, the default values of the names can be modified manually with 

the IFC Manager. 

 

Figure 15   The default naming rule examples of IFC Type Product entities 
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To make all COBie2-required IFC Properties available for the Type elements in the IFC Manager, import the 

“COBie2-PropertySet.xml” scheme into the ArchiCAD project (see chapter Component). The XML-type 

scheme can be added to the project with the IFC Scheme Setup command (File > File Special > IFC 2x3). To 

manage the IFC Attributes, the Properties and the Classification reference items of an IFC Product Type (for 

example the properties of an IfcWindowStyle assigned to an IfcWindow), first set the type object editable 

with the “Edit / New Type” tool, and then define the values of its properties. 

To set the Type Category, define Classification Reference data in the IFC Manager. COBie requires IfcSystem 

classification by the OmniClass table 21 (‘Building Elements'), so choose the proper classification value from 

the built-in “Table 21 – Elements” (OmniClass) list under the “Apply Predefined Rule” option. ArchiCAD 

classification rule based on Uniclass tables is also available in UK. 

 

Figure 16   IFC Properties defined for an IFC Type Product entity (COBie Type item) 
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Component 
 

The COBie2 Component worksheet summarizes the individually named or schedule items of the project. 

 

Figure 17   Mapping between ArchiCAD model and the COBie2 Component worksheet data 

The “Name” data are derived from the ArchiCAD “ID” of the element, so you can set them in the element 

Settings dialogs. 

The “Space” data describe the assigned ArchiCAD Zone (IfcSpace) to a component. This data is automatically 

calculated, if the IFC export uses the Space containment and Space boundaries functions (see chapter 

COBie2-enabled IFC Model Export).  

To make all COBie2-required IFC Properties available for the Component elements in the IFC Manager and 

the Setting Dialogs (Tags and Categories > Manage IFC Properties), import the “COBie2-PropertySet.xml” 

scheme into the ArchiCAD project. The XML-type scheme can be added to the project with the IFC Scheme 

Setup command (File > File Special > IFC 2x3). 
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Figure 18   IFC Properties defined in the “COBie2” predefined scheme 
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System 
 

The COBie2 System worksheet summarizes the sets of Components providing a service. In other words, it 

summarizes the data of the systems (IfcSystem) of the project elements. 

 

Figure 19   Mapping between ArchiCAD model and the COBie2 System worksheet data 

The “Systems” are interpreted as IfcSystem assignment entities in the ArchiCAD project. IfcSystem and their 

COBie2-requested data can be defined in the IFC Manager only. 

First, create an IfcSystem by clicking the “New” command from the “IFC Systems” item in the “Assignments” 

tree, then drop the IFC elements to the “New Relation” folder of the new IfcSystem entity from the Project 

tree of the IFC Manager. 

To set the System Category, define Classification Reference data in the IFC Manager. COBie requires 

IfcSystem classification by the OmniClass table 21 (‘Building Elements'), so choose the proper classification 

value from the built-in “Table 21 – Elements” (OmniClass) list under the “Apply Predefined Rule” option. 

ArchiCAD classification rule based on Uniclass tables is also available in UK. 

 

Figure 20   IfcSystem definition in ArchiCAD 
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MEP Systems can be also handled as IfcSystem inside an ArchiCAD project: 

- If a MEP System is defined by the GRAPHISOFT MEP Modeler, it and its members can be easily 
assigned to an IFC System. Just create a new IfcSystem (mentioned before) and set its Name to the 
required MEP System name (see the next figure). 

- If an IFC model (for example exported by an MEP application) merged to the current ArchiCAD 
project contains IfcSystems, you can also manage them and their properties in the IFC Manager. 

 

Figure 21   Conversion of a MEP Modeler System to an IfcSystem 

 

Document / Attribute / Coordinate / PickLists 
 

Data are extracted automatically from the IFC model exported by ArchiCAD. 

 

Assembly / Connection / Spare / Resource / Job / Impact / Issue 
 

These data types are not requested from a design application by the COBie2 rules, and they are not available 

in ArchiCAD projects too. The table contents should be manually filled out in the spreadsheet, if they are 

required. 
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COBie2-enabled IFC Model Export 
 

The IFC model export using FM Handover View can be easily carried out using the File > Save as command. 

The ”Save as IFC” command is available from either the Floor Plan or 3D window. 

 

Figure 22   IFC model export based on FM Handover View 

The steps of IFC model export: 

1. Element filtering possibilities for the export: 

- Selected elements only (available only if elements have been selected): 

elements selected in the current view (the view that was open when you issued the export 

command) will be exported. 

- Entire project: 

entire model (regardless of any selection, and regardless of the elements’ show/hide status) 

will be exported. 

- Visible elements (on all stories): 

the visible elements in the current view will be exported, regardless of any selection. “Visible” 

means all elements that are set to be displayed (due to layer settings, model view options, 

partial structure display, etc.). 

Note If you issue the export command from Floor Plan view (“Visible elements (on all 

stories)”), this choice includes all elements currently displayed on every story of the 

project. 

- All elements on current story (available only if Floor Plan is open): 

all elements (regardless of any selection, and regardless of the elements’ show/hide status) on 

the current story of the Floor Plan will be exported. 

- Visible elements on current story (available only if Floor Plan is open): 

all elements (regardless of any selection) that are visible on the current story of the Floor Plan 

will be exported. 

 

Note If you choose “Visible elements,” make sure that ArchiCAD Zones are set to be displayed in 

the current view. For example, if you are saving from the 3D window, make sure that Zones 
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are on in the “Filter Elements in 3D” dialog box  (View > Elements in 3D View > Filter 

Elements in 3D). 

 

2. Choose the “FM Handover” Translator, in which export settings are fine-tuned for the FM Handover 

requirements. 

Note If the “FM Handover” Translator is not available in ArchiCAD, you must create such a 

Translator, by clicking the “Settings” button in the “IFC Translation Setup” dialog. 

1. Duplicate the built-in “General Translator” and rename it to “FM Handover”. 

2. Set “Extended Model View” for “IFC View Definition” (Export Options). 

3. Type “FMHandover” text in the “Extended Model View name” field (Export Options). 

This text defines the identification of the FM Handover View Definition in the header of 

the exported IFC file. 

4. Activate the following options at Export Options (Derived model data to export): 

- “Space containment”: it exports the relationship between ArchiCAD Zones 

(IfcSpaces) and Furnishing, Mechanical (HVAC) and other contained elements 

within the space. The option is required for exporting “Space” data of the 

Component tab in the COBie2 Spreadsheet. 

- “Base quantities (length, area and volume)”: it exports base quantities including 

data required by COBie2. 

- “IFC Space boundaries with tolerance between Zones [mm]”: it exports the logical 

connection between ArchiCAD Zones (IfcSpace) and the building elements that 

enclose them. The “tolerance between Zones” means the maximum distance 

between neighboring ArchiCAD Zones (for example, the thickest wall/slab) in mm. 

The option is required for exporting “Space” data of the Component tab in the 

COBie2 Spreadsheet. 

5. Set the unit system for the exported model (Export Options > IFC model units). 

6. Click “Save Settings & Close”. 
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Figure 23   Major export options of the IFC translator set for the FM Handover requirements 

 

3. Define file name. 

 

4. Choose the file format of the IFC export. Choose .IFC or .IFCXML depending on the file support of the 

COBie2 spreadsheet converter programs (see the How to Create a COBie2 Spreadsheet chapter). 

 

5. Click Save. 

  



23 
 

How to Create a COBie2 Spreadsheet 
 

An external application is needed for the conversion of an ArchiCAD IFC file to an XLS/XML-type COBie2 

spreadsheet format. 

The IFC, IFCXML and COBie2 spreadsheet formats for the IFC 2x3 FM Handover MVD do capture the same 

information content and can be transformed forth and back across the different formats. There are some 

dedicated tools can be used to execute the transformations, such as the no-cost application, developed by 

Engineer Research and Development Center (ERDC), called COBie Toolkit. 

ERDC COBie Toolkit, developed for the COBie FM Handover project, includes the transformer tool and the 

configurations to map IFC data to COBie2. 

Hint COBie Toolkit is a free tool and can be downloaded from  (not available yet). here
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